Checks if given reference identifies part of object identified by this reference.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool Contains(
Reference reference
)
Public Function Contains (
reference As Reference
) As Boolean
public:
bool Contains(
Reference^ reference
)
member Contains :
reference : Reference -> bool
Parameters
- reference Reference
- Another reference.
Return Value
BooleanReturns true if given reference identifies part of object identified by this reference, false otherwise.
Exceptions
Remarks
Can be used to check:
- If given Reference is a part of a particular Subelement identified by this Reference.
- If given Reference is a part of a particular Element identified by this Reference.
The input reference can refer to a subelement or a specific geometric item from an element or subelement.
See Also