TransformScaleBasis Method |
Scales the basis vectors of this transformation and returns the result.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Transform ScaleBasis(
double scale
)
Public Function ScaleBasis (
scale As Double
) As Transform
public:
Transform^ ScaleBasis(
double scale
)
member ScaleBasis :
scale : float -> Transform
Parameters
- scale Double
- The scale value.
Return Value
TransformThe transformation equal to the composition of the two transformations.
ExceptionsException | Condition |
---|
ArgumentException |
Thrown when the specified value is an infinite number.
|
Remarks
The resulting transformation is equivalent to the application of the uniform scale
and then this transformation, in this order.
See Also