BoundingBoxContainsPointFilter(XYZ, Boolean) Constructor |
Constructs a new instance of a filter to match elements with a bounding box that contains the given point,
with the option to invert the filter and match all elements with a bounding box that do not contain the given point.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic BoundingBoxContainsPointFilter(
XYZ point,
bool inverted
)
Public Sub New (
point As XYZ,
inverted As Boolean
)
public:
BoundingBoxContainsPointFilter(
XYZ^ point,
bool inverted
)
new :
point : XYZ *
inverted : bool -> BoundingBoxContainsPointFilter
Parameters
- point XYZ
-
The point used to find elements with a bounding box containing it.
- inverted Boolean
-
True if the filter should be inverted and match all elements with a bounding box that do not contain the given point.
Exceptions
See Also