PointOnPlaneIsValidPlaneReference Method |
Check whether a geometry reference
corresponds to a referenceable plane.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsValidPlaneReference(
Document doc,
Reference planeReference
)
Public Shared Function IsValidPlaneReference (
doc As Document,
planeReference As Reference
) As Boolean
public:
static bool IsValidPlaneReference(
Document^ doc,
Reference^ planeReference
)
static member IsValidPlaneReference :
doc : Document *
planeReference : Reference -> bool
Parameters
- doc Document
-
- planeReference Reference
-
Return Value
Boolean
RemarksValid plane references include: planar faces
of solids; the PlaneReference properties of
Level and
SketchPlane;
the Reference property of
ReferencePlane.
See Also