HostObjectUtilsGetBottomFaces Method |
Returns the bottom faces for this host object.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static IList<Reference> GetBottomFaces(
HostObject hostObject
)
Public Shared Function GetBottomFaces (
hostObject As HostObject
) As IList(Of Reference)
public:
static IList<Reference^>^ GetBottomFaces(
HostObject^ hostObject
)
static member GetBottomFaces :
hostObject : HostObject -> IList<Reference>
Parameters
- hostObject HostObject
-
The host object.
Return Value
IListReference
An array of references to the faces which are at the bottom of this element.
Exceptions
Remarks
This utility supports host objects whose bottom faces represent one of the boundaries
of CompoundStructure (such as roofs, floors or ceilings).
See Also