EntityGetFieldType(String) Method

Retrieves the value of the field in the entity.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FieldType Get<FieldType>(
	string fieldName
)

Parameters

fieldName  String
The name of the field to retrieve.

Type Parameters

FieldType
The type of the field

Return Value

FieldType
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was NULL
InvalidOperationException The Field belongs to a different Schema from this Entity, or this Entity is invalid.
ArgumentException Requested type does not match the field type.
ArgumentException The name matches no field in this Entity's Schema.
ArgumentException For floating-point fields, use the overload taking a ForgeTypeId parameter.
ArgumentException This field's subschema prevents reading.
Remarks

The template parameter must match the type of the field (specified when creating the Schema) exactly; this method does not perform data type conversions. The types for containers are IList for arrays and IDictionary for maps.

This method is a shortcut that will look up the field by name. If you want to call it on many entities, it is faster if you look up the field yourself.

See Also