SpatialElementTagLeaderEnd Property

The position of the leader's end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public XYZ LeaderEnd { get; set; }

Property Value

XYZ
Exceptions
ExceptionCondition
ArgumentException When setting this property: The point is located outside of the spatial element.
ArgumentNullException When setting this property: A non-optional argument was null
InvalidOperationException There is no leader for this tag. -or- When setting this property: SpatialElementTag is pinned. -or- When setting this property: SpatialElementTag is orphaned.
Remarks
Returns the end point of the tag leader. Leader end point must be located inside of a room, space or an area. Use Room.IsPointInRoom or Space.IsPointInSpace method to check whether the leaderEnd is located in the host element or not.
See Also