FamilyManagerSortParameters Method |
Sorts the family parameters according to the desired sort order.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SortParameters(
ParametersOrder order
)
Public Sub SortParameters (
order As ParametersOrder
)
public:
void SortParameters(
ParametersOrder order
)
member SortParameters :
order : ParametersOrder -> unit
Parameters
- order ParametersOrder
-
The desired sort order.
ExceptionsException | Condition |
---|
InvalidOperationException |
Thrown when this family is a Rebar Shape family which doesn't support parameters reorder.
|
RemarksThe sort only affects visible parameters within the same parameter group.
Parameters that belong to different groups will remain separated, and the groups' order will not be affected.
The sort is a one-time operation and when new parameters are added they will not be automatically sorted.
Exampleprivate void DisplayParametersInAscendingOrder(Document familyDoc)
{
FamilyManager familyManager = familyDoc.FamilyManager;
familyManager.SortParameters(ParametersOrder.Ascending);
}
Private Sub DisplayParametersInAscendingOrder(familyDoc As Document)
Dim familyManager As FamilyManager = familyDoc.FamilyManager
familyManager.SortParameters(ParametersOrder.Ascending)
End Sub
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also