WorksharingDisplaySettingsGetOrCreateWorksharingDisplaySettings Method |
Returns the worksharing display settings for the document, creating
new settings for the current user if necessary.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static WorksharingDisplaySettings GetOrCreateWorksharingDisplaySettings(
Document doc
)
Public Shared Function GetOrCreateWorksharingDisplaySettings (
doc As Document
) As WorksharingDisplaySettings
public:
static WorksharingDisplaySettings^ GetOrCreateWorksharingDisplaySettings(
Document^ doc
)
static member GetOrCreateWorksharingDisplaySettings :
doc : Document -> WorksharingDisplaySettings
Parameters
- doc Document
-
The document of interest.
Return Value
WorksharingDisplaySettings
The worksharing display settings for the document.
Exceptions
Remarks
Note that these settings are available even in models that are not
workshared. This is to allow pre-configuring the display settings
before enabling worksets so that they can be stored in template files.
See Also