NumberingSchemaGetNumbers Method |
Returns all numbers currently used in the given numbering sequence
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<IntegerRange> GetNumbers(
string partition
)
Public Function GetNumbers (
partition As String
) As IList(Of IntegerRange)
public:
IList<IntegerRange^>^ GetNumbers(
String^ partition
)
member GetNumbers :
partition : string -> IList<IntegerRange>
Parameters
- partition String
-
Name of the partition that identifies the sequence. The sequence must exist.
Return Value
IListIntegerRange
A collection of integer ranges
Exceptions
RemarksNumbers are returned as a collection of ranges, where each range
is a pair of two integer values, Low and High. As long as there is
no gap currently in the sequence, there will be only one range.
See Also