ParameterFilterElementAllRuleParametersApplicable(ElementFilter) Method |
Checks that the parameters of the rules used by the given ElementFilter are valid for this filter's categories.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool AllRuleParametersApplicable(
ElementFilter elementFilter
)
Public Function AllRuleParametersApplicable (
elementFilter As ElementFilter
) As Boolean
public:
bool AllRuleParametersApplicable(
ElementFilter^ elementFilter
)
member AllRuleParametersApplicable :
elementFilter : ElementFilter -> bool
Parameters
- elementFilter ElementFilter
-
The ElementFilter containing the rules to check.
Return Value
Boolean
True if all the parameters of the given rules are valid for this filter, otherwise false.
Exceptions
See Also