The Discipline of the view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ViewDiscipline Discipline { get; set; }
Public Property Discipline As ViewDiscipline
Get
Set
public:
property ViewDiscipline Discipline {
ViewDiscipline get ();
void set (ViewDiscipline value);
}
member Discipline : ViewDiscipline with get, set
Property Value
ViewDiscipline
ExceptionsException | Condition |
---|
ArgumentOutOfRangeException |
When setting this property: A value passed for an enumeration argument is not a member of that enumeration
|
InvalidOperationException |
View must have a Discipline property
-or-
When setting this property: View Discipline must be modifiable.
|
See Also