ReferencePointSetPointElementReference Method |
Change the rule for computing the
location of the ReferencePoint relative to other elements in
the document.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetPointElementReference(
PointElementReference pointElementReference
)
Public Sub SetPointElementReference (
pointElementReference As PointElementReference
)
public:
void SetPointElementReference(
PointElementReference^ pointElementReference
)
member SetPointElementReference :
pointElementReference : PointElementReference -> unit
Parameters
- pointElementReference PointElementReference
- An object specifying
a rule for the location and orientation of a ReferencePoint.
(Note: The ReferencePoint object does not store the
pointElementReference object after this call.)
ExceptionsException | Condition |
---|
InvalidOperationException |
Thrown when Reference is set to a non-null object, and the
ReferencePoint is unable to move to the new reference.
|
RemarkspointElementReference may be , in which case the ReferencePoint
does not follow any other element. When Reference is changed
from to a non-null value, the point moves and rotates
to the prescribed location and orientation. Where the
coordinate system has some freedom, it will remain as close
to the old orientation as possible. When
the reference is set to , the point does not move or
rotate.
See Also