GeometryElementGetBoundingBox Method |
Retrieves a box that encloses the geometry element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic BoundingBoxXYZ GetBoundingBox()
Public Function GetBoundingBox As BoundingBoxXYZ
public:
BoundingBoxXYZ^ GetBoundingBox()
member GetBoundingBox : unit -> BoundingBoxXYZ
Return Value
BoundingBoxXYZThe bounding box.
RemarksNote: If the GeometryElement was obtained via Element.get_Geometry from an Element containing 2D geometry
but no 3D geometry, the bounding box returned by this function may not be empty because it takes the 2D geometry into account.
See Also