EndCapCondition Enumeration |
Used by CompoundStructure to describe which shell layers participate in end wrapping.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum EndCapCondition
Public Enumeration EndCapCondition
public enum class EndCapCondition
MembersMember name | Value | Description |
---|
None | 0 |
None of the shell layers participate in end wrapping.
|
Exterior | 1 |
Only the exterior shell layers participate in end wrapping.
|
Interior | 2 |
Only the interior shell layers participate in end wrapping.
|
NoEndCap | 3 |
No end wrapping ability. Floors and roofs must use this enum value.
|
See Also