FabricationPartBrowserOperation Enumeration

Operations for the FabricationPartBrowserChangedEventArgs Event

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum FabricationPartBrowserOperation
Members
Member nameValueDescription
ShowBrowser0 Show browser window
HideBrowser1 Hide browser window
ShowService2 Select current service
StartRoutingSolutionMode3 Start routing solution mode
CreatedRoutingSolutions4 Routing solutions (re)created
RoutingSolutionChanged5 Active Routing solution has changed
FinishRoutingSolutionMode6 Finish routing solution mode
StartMPRoutingMode7 Start multi-point routing mode
FinishMPRoutingMode8 Finish multi-point routing mode
StartServiceSwapOutMode9 Start service swap-out mode
UnknownOperation-1 Unknown operation
FinishServiceSwapOutMode10 Finish service swap-out mode
UpdateServiceSwapOutPartTypes11 Service swap out part type mappings has changed.
UpdateServiceSwapOutSizes12 Service swap out size mappings has changed.
StartSizeSwapOutMode13 Start size swap-out mode.
FinishSizeSwapOutMode14 Finish size swap out mode.
SwitchToInlineFittingsTab15 Make the inline fittings tab active in Change Service.
See Also