EntitySetFieldType(String, FieldType) Method

Stores the value of the field in the entity.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void Set<FieldType>(
	string fieldName,
	FieldType value
)

Parameters

fieldName  String
The name of the field to update.
value  FieldType
 

Type Parameters

FieldType
The type of the field
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was NULL
InvalidOperationException The Field belongs to a different Schema from this Entity, or this Entity is invalid.
ArgumentException Requested type does not match the field type.
ArgumentException The name matches no field in this Entity's Schema.
ArgumentException For floating-point fields, use the overload taking a ForgeTypeId parameter.
ArgumentException This field's subschema prevents writing.
ArgumentException Invalid floating-point value.
ArgumentException String is too long; exceeds max length of 16mb characters.
Remarks

The template parameter must match the type of the field (specified when creating the Schema) exactly; this method does not perform data type conversions. The types for containers are IList for arrays and IDictionary for maps.

Note that when string values are specified as map keys, they are case-insensitive.

This method only modifies your copy of the Entity. Store the Entity in an element or another Entity to save the new value. Write access check is not performed on each call to Set. Instead, write access is checked when you try to save the Entity in an Element or another Entity.

This method is a shortcut that will look up the field by name. If you want to call it on many entities, it is faster if you look up the field yourself.

See Also