AngularDimensionCreate Method |
Creates a new instance of an Angular Dimension element within the project.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static AngularDimension Create(
Document document,
View dbView,
Arc arc,
IList<Reference> references,
DimensionType dimensionStyle
)
Public Shared Function Create (
document As Document,
dbView As View,
arc As Arc,
references As IList(Of Reference),
dimensionStyle As DimensionType
) As AngularDimension
public:
static AngularDimension^ Create(
Document^ document,
View^ dbView,
Arc^ arc,
IList<Reference^>^ references,
DimensionType^ dimensionStyle
)
static member Create :
document : Document *
dbView : View *
arc : Arc *
references : IList<Reference> *
dimensionStyle : DimensionType -> AngularDimension
Parameters
- document Document
-
The document where new Angular Dimension is created.
- dbView View
-
The view in which the Angular Dimension will appear.
- arc Arc
-
Arc for the Angular Dimension.
- references IListReference
-
The references which the Angular Dimension will witness.
- dimensionStyle DimensionType
-
Dimension Style.
Return Value
AngularDimension
The newly created Angular Dimension instance, or
if the operation fails.
ExceptionsException | Condition |
---|
ArgumentException |
References should be: at least two, non parallel and rays of the arc passed.
|
ArgumentNullException |
A non-optional argument was null
|
ModificationForbiddenException |
The document is in failure mode: an operation has failed,
and Revit requires the user to either cancel the operation
or fix the problem (usually by deleting certain elements).
-or-
The document is being loaded, or is in the midst of another
sensitive process.
|
ModificationOutsideTransactionException |
The document has no open transaction.
|
See Also