RebarShapeDrivenAccessorUseRebarConstraintsToProduceVaryingBars Property

Identifies if the rebar constraints should be used to compute each bar in set (which can produce varying length bars).

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool UseRebarConstraintsToProduceVaryingBars { get; set; }

Property Value

Boolean
Remarks

If this is false, only the first bar will be computed based on constraints and all the other bars will be a copy of it, each in their respective positions within the set. Only for the first bar in set the distance from its handle to the target in constraint is the offset value stored in the constraint.

If this is true, for each bar in set the constraints will be used to compute the bar. For each bar in set the distance from its handle to the target in constraint is the offset value stored in the constraint.

Even if this property is set to true, the set may have all bars identical. An example of such case is when all handles' surfaces(planes) are parallel with constraint' target surface(plane)

See Also