DirectShapeTypeUserAssignability Enumeration |
Options for a DirectShapeType which affect whether or not it can be assigned as the type of a DirectShape.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum DirectShapeTypeUserAssignability
Public Enumeration DirectShapeTypeUserAssignability
public enum class DirectShapeTypeUserAssignability
type DirectShapeTypeUserAssignability
MembersMember name | Value | Description |
---|
Assignable | 0 |
The DirectShapeType can be used to replace the type of an existing DirectShape.
|
Nonassignable | 1 |
The DirectShapeType cannot be used to replace the type of an existing DirectShape.
|
Remarks
Only DirectShapeTypes which permit assignability will be shown in the type selector dialog.
A DirectShape which uses a DirectShapeType which is not assignable can be copied.
See Also