MechanicalSystemGetFlow Method |
Gets the flow of this mechanical system.
Namespace: Autodesk.Revit.DB.MechanicalAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
SyntaxPublic Function GetFlow As Double
member GetFlow : unit -> float
Return Value
Double
Exceptions
Remarks
The system flow is calculated in the non-blocking evaluation framework. The caller may set up callbacks that react to the asynchronous calculation results.
If no callback is set up (e.g, called from third-party applications), the calculation is automatically switched to synchronous calculation so the caller
can access the up-to-date result. Similarly, the public method get_ParameterValue(BuiltInParameter.RBS_DUCT_FLOW_PARAM) has the same behavior. Due to this
change, the parameter RBS_DUCT_FLOW_PARAM no longer supports dynamic model update.
See Also