ObjectType Enumeration

This enumerated type contains object types allowed to be selected during selection operations.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum ObjectType
Members
Member nameValueDescription
Nothing0 Nothing.
Element1 Whole element.
PointOnElement2 Any point on an element (on a face or curve).
Edge3 Any model edge.
Face4 Any face.
LinkedElement5 Elements in linked RVT files.
Subelement6 Whole element or subelement.
See Also