FabricSheetTypeGetWireItem Method

Gets the Wire stored in the FabricSheetType at the associated index.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FabricWireItem GetWireItem(
	int wireIndex,
	WireDistributionDirection direction
)

Parameters

wireIndex  Int32
Item index in the Fabric Sheet
direction  WireDistributionDirection
Wire distribution direction of the inquired item

Return Value

FabricWireItem
Fabric wire Item
Exceptions
ExceptionCondition
ArgumentException The item index is either less than 0 or greater than or equal to number of items in this FabricSheetType.
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException Fabric Sheet is not Custom
See Also