FilteredWorksetCollectorFirstWorkset Method |
Returns the first workset to pass the filter(s).
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Workset FirstWorkset()
Public Function FirstWorkset As Workset
public:
Workset^ FirstWorkset()
member FirstWorkset : unit -> Workset
Return Value
Workset
The first workset.
ExceptionsException | Condition |
---|
InvalidOperationException |
The collector does not have a filter applied. Extraction or iteration of worksets is not permitted without a filter.
|
Remarks
This will reset the collector to the beginning and find the first workset that passes the applied filter(s).
If you have an active iterator to this same collector it will be stopped by this call.
See Also