MEPSize Constructor

Constructs an object that stores the basic size information for MEP duct, pipe, cable tray and conduit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public MEPSize(
	double nominalDiameter,
	double innerDiameter,
	double outerDiameter,
	bool usedInSizeLists,
	bool usedInSizing
)

Parameters

nominalDiameter  Double
Nominal diameter. The value should be a valid, positive Revit length.
innerDiameter  Double
Inner diameter. The value should be a valid, positive Revit length.
outerDiameter  Double
Outer diameter. The value should be a valid, positive Revit length.
usedInSizeLists  Boolean
Whether it is used in size lists.
usedInSizing  Boolean
Whether is used in sizing.
Exceptions
ExceptionCondition
ArgumentOutOfRangeException The given value for nominalDiameter must be greater than 0 and no more than 30000 feet. -or- The given value for innerDiameter must be greater than 0 and no more than 30000 feet. -or- The given value for outerDiameter must be greater than 0 and no more than 30000 feet.
See Also