gbXMLOpeningType Enumeration |
This enumeration corresponds to the openingType attribute in gbXML
and identifies the type of opening defined.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum gbXMLOpeningType
Public Enumeration gbXMLOpeningType
public enum class gbXMLOpeningType
MembersMember name | Value | Description |
---|
FixedWindow | 0 |
Fixed window.
|
OperableWindow | 1 |
Operable window.
|
FixedSkylight | 2 |
Fixed skylight.
|
OperableSkylight | 3 |
Operable skylight.
|
SlidingDoor | 4 |
Sliding door.
|
NonSlidingDoor | 5 |
Non sliding door.
|
OpeningAir | 6 |
Opening air.
|
NoOfOpeningTypes | 7 |
No of opening types.
|
See Also