EnergyAnalysisSurfaceCADObjectUniqueId Property |
The unique id of the originating CAD object (model element) associated with this surface.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic string CADObjectUniqueId { get; }
Public ReadOnly Property CADObjectUniqueId As String
Get
public:
property String^ CADObjectUniqueId {
String^ get ();
}
member CADObjectUniqueId : string with get
Property Value
String
Remarks
This id can be passed to obtain the element from Document.Element[string] property, but any element obtained through this method
may no longer be a valid or up-to-date model element. The originating CAD object is only accurate and up-to-date at the time of creation of the energy model.
If the originating element belongs to a linked document, the unique id of the link obtained from CADLinkUniqueId should be used to access it.
See Also