FamilyPlacementType Enumeration |
The type of placement required for a given family.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum FamilyPlacementType
Public Enumeration FamilyPlacementType
public enum class FamilyPlacementType
MembersMember name | Value | Description |
---|
OneLevelBased | 0 |
The family is placed referencing a single level.
|
OneLevelBasedHosted | 1 |
The family is placed referencing a single level and host.
|
TwoLevelsBased | 2 |
The family is placed referencing two levels (e.g. a column).
|
ViewBased | 3 |
The family is view-specific (e.g. a detail annotation)
|
WorkPlaneBased | 4 |
The family is placed on a work plane or face.
|
CurveBased | 5 |
The family is based on a line and placed on a work plane.
|
CurveBasedDetail | 6 |
The family is based on a line and place on a specific view (e.g. a detail component).
|
CurveDrivenStructural | 7 |
The family is a structural curve driven member (beam, brace, or slanted column)
|
Adaptive | 8 |
The family is an adaptive family.
|
Invalid | 9 |
This signals an invalid value for the enum.
|
See Also