ViewScheduleMergeSegments Method |
Merges two adjacent segments into one.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void MergeSegments(
int movedSegmentIndex,
int targetSegmentIndex
)
Public Sub MergeSegments (
movedSegmentIndex As Integer,
targetSegmentIndex As Integer
)
public:
void MergeSegments(
int movedSegmentIndex,
int targetSegmentIndex
)
member MergeSegments :
movedSegmentIndex : int *
targetSegmentIndex : int -> unit
Parameters
- movedSegmentIndex Int32
-
The index of the moved segment.
- targetSegmentIndex Int32
-
The index of the target segment.
ExceptionsException | Condition |
---|
ArgumentException |
Only two adjacent segments can be merged.
-or-
The segment index should start from 0 and be less than the total segment count.
|
Remarks
Only adjacent segments can be merged. The moved segment will be deleted with all its instances
on sheet and all the data will be merged into the target segment with height expanded.
See Also