SlabShapeEditorAddSplitLine Method |
Add a split line to the element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<SlabShapeCrease> AddSplitLine(
SlabShapeVertex startVertex,
SlabShapeVertex endVertex
)
Public Function AddSplitLine (
startVertex As SlabShapeVertex,
endVertex As SlabShapeVertex
) As IList(Of SlabShapeCrease)
public:
IList<SlabShapeCrease^>^ AddSplitLine(
SlabShapeVertex^ startVertex,
SlabShapeVertex^ endVertex
)
member AddSplitLine :
startVertex : SlabShapeVertex *
endVertex : SlabShapeVertex -> IList<SlabShapeCrease>
Parameters
- startVertex SlabShapeVertex
-
Start vertex
- endVertex SlabShapeVertex
-
End vertex
Return Value
IListSlabShapeCrease
The newly created creases after adding the split line.
Exceptions
Remarks
Adding a split line may result in multiple creases, for example when the line crosses existing creases or boundary edges.
See Also