PointCloudTypeCreate Method |
Creates a new point cloud type for a given point cloud engine.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static PointCloudType Create(
Document document,
string engineIdentifier,
string typeIdentifier
)
Public Shared Function Create (
document As Document,
engineIdentifier As String,
typeIdentifier As String
) As PointCloudType
public:
static PointCloudType^ Create(
Document^ document,
String^ engineIdentifier,
String^ typeIdentifier
)
static member Create :
document : Document *
engineIdentifier : string *
typeIdentifier : string -> PointCloudType
Parameters
- document Document
-
The document in which to create the point cloud.
- engineIdentifier String
-
The string identifying the engine to be invoked.
It should be the file extension or engine identifier registered by the third party.
- typeIdentifier String
-
The file name or the identification string for a non-file based engine.
Return Value
PointCloudType
The newly created PointCloudType object to be used to create instances of
this point cloud.
Exceptions
Remarks
A list of supported engine identifiers and whether they are file-based or not can be
obtained from PointCloudEngineRegistry. The method GetSupportedEngines() returns a list
of the identifiers registered for engines.
Exampleprivate PointCloudInstance CreatePointCloud(Document doc)
{
PointCloudType type = PointCloudType.Create(doc, "rcs", "c:\\32_cafeteria.rcs");
return (PointCloudInstance.Create(doc, type.Id, Transform.Identity));
}
Private Function CreatePointCloud(doc As Document) As PointCloudInstance
Dim type As PointCloudType = PointCloudType.Create(doc, "rcs", "c:\32_cafeteria.rcs")
Return (PointCloudInstance.Create(doc, type.Id, Transform.Identity))
End Function
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also