DisparityResponse Enumeration |
An enumerated value to return from OnServerDiparity indicating
what the service wants Revit to do as the post-action of the call.
Namespace: Autodesk.Revit.DB.ExternalServiceAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum DisparityResponse
Public Enumeration DisparityResponse
public enum class DisparityResponse
MembersMember name | Value | Description |
---|
DoNothing | 0 |
Revit is instructed to do nothing. It is assumed that the service
already handled what needed to be handled (e.g. it set servers
appropriately to the situation.)
|
ApplyDefaults | 1 |
Revit is to apply the default algorithm which is to activate
just the servers that are remaining available. It could also
mean that no server will be set at all if the servers previously
used in the document are not currently registered. If such a
situation happens for a mandatory service, then the service's
default server will be set as the new (and only) active server.
|
LetUserDecide | 2 |
Revit is to prompt the end-user to let him or her decide
whether a default action should be applied or a selection
of servers should be set.
|
See Also