BoundingBoxXYZTransform Property |
The transform from the coordinate space of the box to the model coordinate space.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Transform Transform { get; set; }
Public Property Transform As Transform
Get
Set
public:
property Transform^ Transform {
Transform^ get ();
void set (Transform^ value);
}
member Transform : Transform with get, set
Property Value
Transform
RemarksThe transform must always be right-handed and orthonormal.
Exampleprivate void RotateBoundingBox(View3D view3d)
{
if (!view3d.IsSectionBoxActive)
{
TaskDialog.Show("Revit","The section box for View3D isn't active.");
return;
}
BoundingBoxXYZ box = view3d.GetSectionBox();
XYZ origin = new XYZ(0, 0, 0);
XYZ axis = new XYZ(0, 0, 1);
Transform rotate = Transform.CreateRotationAtPoint(axis, Math.PI/6.0, origin);
box.Transform = box.Transform.Multiply(rotate);
view3d.SetSectionBox(box);
}
Private Sub RotateBoundingBox(view3d As View3D)
If Not view3d.IsSectionBoxActive Then
TaskDialog.Show("Revit", "The section box for View3D isn't active.")
Return
End If
Dim box As BoundingBoxXYZ = view3d.GetSectionBox()
Dim origin As New XYZ(0, 0, 0)
Dim axis As New XYZ(0, 0, 1)
Dim rotate As Transform = Transform.CreateRotationAtPoint(axis, Math.PI / 6.0, origin)
box.Transform = box.Transform.Multiply(rotate)
view3d.SetSectionBox(box)
End Sub
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also