ViewScheduleCreateViewList Method

Creates a view list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ViewSchedule CreateViewList(
	Document document
)

Parameters

document  Document
The document to which the new schedule will be added.

Return Value

ViewSchedule
The newly created schedule.
Exceptions
ExceptionCondition
ArgumentException document is not a project document.
ArgumentNullException A non-optional argument was null
ModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException The document has no open transaction.
Remarks
A view list is a schedule of views in the project. It is a schedule of the Views category.
See Also