RebarContainerAppendItemFromRebarShape Method |
Appends an Item to the RebarContainer. Fills its data on base of the Rebar.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic RebarContainerItem AppendItemFromRebarShape(
RebarShape rebarShape,
RebarBarType barType,
XYZ origin,
XYZ xVector,
XYZ yVector
)
Public Function AppendItemFromRebarShape (
rebarShape As RebarShape,
barType As RebarBarType,
origin As XYZ,
xVector As XYZ,
yVector As XYZ
) As RebarContainerItem
public:
RebarContainerItem^ AppendItemFromRebarShape(
RebarShape^ rebarShape,
RebarBarType^ barType,
XYZ^ origin,
XYZ^ xVector,
XYZ^ yVector
)
member AppendItemFromRebarShape :
rebarShape : RebarShape *
barType : RebarBarType *
origin : XYZ *
xVector : XYZ *
yVector : XYZ -> RebarContainerItem
Parameters
- rebarShape RebarShape
-
A RebarShape element that defines the shape of the rebar.
- barType RebarBarType
-
A RebarBarType element that defines bar diameter, bend radius and material of the rebar.
- origin XYZ
-
The lower-left corner of the shape's bounding box will be placed at this point in the project.
- xVector XYZ
-
The x-axis in the shape definition will be mapped to this direction in the project.
- yVector XYZ
-
The y-axis in the shape definition will be mapped to this direction in the project.
Return Value
RebarContainerItem
The Rebar Container Item.
Exceptions
See Also