Entity(Guid) Constructor

Creates a new Entity corresponding to the Schema of the specified GUID.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Entity(
	Guid schemaGUID
)

Parameters

schemaGUID  Guid
 
Exceptions
ExceptionCondition
ArgumentException The GUID does not correspond to any Schema in memory.
InvalidOperationException Writing of Entities of this Schema is not allowed to the current add-in.
Remarks
You can store the newly created Entity in an Element or in another Entity. If you do not have write access to the Schema, an exception will be thrown. If the GUID does not correspond to a known Schema, the Entity will be invalid and an exception will be thrown.
See Also