RebarConstraintGetTargetRebarConstraintType Method |
Returns the TargetRebarConstraintType of the handle on the other Rebar Element
to which this RebarConstraint is attached. The RebarConstraintType of the
RebarConstraint must be 'ToOtherRebar'.
Rebar must be Shape Driven Rebar element.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic TargetRebarConstraintType GetTargetRebarConstraintType()
Public Function GetTargetRebarConstraintType As TargetRebarConstraintType
public:
TargetRebarConstraintType GetTargetRebarConstraintType()
member GetTargetRebarConstraintType : unit -> TargetRebarConstraintType
Return Value
TargetRebarConstraintType
ExceptionsException | Condition |
---|
InvalidOperationException |
RebarConstraint is no longer valid.
-or-
The RebarConstraint is not of RebarConstraintType 'ToOtherRebar'.
-or-
Constrained rebar isn't a shape driven rebar element.
|
See Also