CompoundStructureGetAdjacentRegions Method |
Gets the ids of region bound to a specified segment.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<int> GetAdjacentRegions(
int segmentId
)
Public Function GetAdjacentRegions (
segmentId As Integer
) As IList(Of Integer)
public:
IList<int>^ GetAdjacentRegions(
int segmentId
)
member GetAdjacentRegions :
segmentId : int -> IList<int>
Parameters
- segmentId Int32
-
The id of a segment in this CompoundStructure.
Return Value
IListInt32
The ids of the regions that are bounded by the specified segment.
Exceptions
Remarks
The boundaries of the regions of a vertically compound structure consist of vertical
horizontal segments with unique ids.
The segments which define the outer boundary of the structure are adjacent to one region,
other segments will be adjacent to two regions.
See Also