MultiReferenceAnnotationTypeCreateDefault Method |
Creates the first MultiReferenceAnnotationType element and adds it to the document.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static MultiReferenceAnnotationType CreateDefault(
Document document
)
Public Shared Function CreateDefault (
document As Document
) As MultiReferenceAnnotationType
public:
static MultiReferenceAnnotationType^ CreateDefault(
Document^ document
)
static member CreateDefault :
document : Document -> MultiReferenceAnnotationType
Parameters
- document Document
-
The document to be modified.
Return Value
MultiReferenceAnnotationType
The new MultiReferenceAnnotationType element.
ExceptionsException | Condition |
---|
ArgumentException |
document is not a project document.
-or-
There are existing MultiReferenceAnnotationTypes in the document.
|
ArgumentNullException |
A non-optional argument was null
|
Remarks
If there is no existing MultiReferenceAnnotationType a new one will be created, otherwise an exception will be thrown.
Use
Duplicate(String) to create all further MultiReferenceAnnotationTypes.
The default MultiReferenceAnnotationType will use the document's current default
linear dimension style and will have Structural Rebar as its reference category.
No tag type will be set for the new MultiReferenceAnnotationType.
See Also