SketchPlaneCreate(Document, Plane) Method |
Creates a new sketch plane from a geometric plane.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static SketchPlane Create(
Document document,
Plane plane
)
Public Shared Function Create (
document As Document,
plane As Plane
) As SketchPlane
public:
static SketchPlane^ Create(
Document^ document,
Plane^ plane
)
static member Create :
document : Document *
plane : Plane -> SketchPlane
Parameters
- document Document
-
The document.
- plane Plane
-
The geometry plane where the sketch plane will be created.
Return Value
SketchPlane
The newly created sketch plane.
Exceptions
Remarks
There will not be a reference relationship established from the sketch plane to the input face. To create a SketchPlane with a reference to other geometry,
use the overload with a Reference input.
Examplepublic static SketchPlane CreateSketchPlane(Autodesk.Revit.DB.Document document, Plane plane)
{
SketchPlane sketchPlane = null;
sketchPlane = SketchPlane.Create(document, plane);
if (null == sketchPlane)
{
throw new Exception("Create the sketch plane failed.");
}
return sketchPlane;
}
Public Shared Function CreateSketchPlane(document As Autodesk.Revit.DB.Document, plane As Plane) As SketchPlane
Dim sketchPlane__1 As SketchPlane = Nothing
sketchPlane__1 = SketchPlane.Create(document, plane)
If sketchPlane__1 Is Nothing Then
Throw New Exception("Create the sketch plane failed.")
End If
Return sketchPlane__1
End Function
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also