PerformanceAdviserIsRuleEnabled(PerformanceAdviserRuleId) Method

Retrieves an enabled/disabled status for the given rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsRuleEnabled(
	PerformanceAdviserRuleId id
)

Parameters

id  PerformanceAdviserRuleId
The rule id to retrieve enabled/disabled status for.

Return Value

Boolean
True if rule is disabled, false otherwise.
Exceptions
ExceptionCondition
ArgumentException The id does not correspond to any registered rule.
ArgumentNullException A non-optional argument was null
See Also