MetalPerforationsType Enumeration |
The enumerated type representing the permitted values for the asset property "MetalPerforations" from the "Metal" schema.
Namespace: Autodesk.Revit.DB.VisualAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum MetalPerforationsType
Public Enumeration MetalPerforationsType
public enum class MetalPerforationsType
type MetalPerforationsType
MembersMember name | Value | Description |
---|
None | 0 | |
CirclesStaggered | 1 | |
CirclesStraight | 2 | |
Squares | 3 | |
Grecian | 4 | |
Cloverleaf | 5 | |
Hexagon | 6 | |
Custom | 7 | |
See Also