PropertySetElementDuplicate Method |
Creates a duplicate of this PropertySetElement.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic PropertySetElement Duplicate(
Document document,
string name
)
Public Function Duplicate (
document As Document,
name As String
) As PropertySetElement
public:
PropertySetElement^ Duplicate(
Document^ document,
String^ name
)
member Duplicate :
document : Document *
name : string -> PropertySetElement
Parameters
- document Document
-
The document in which to create the PropertySetElement.
- name String
-
The name to use for the new PropertySetElement.
Return Value
PropertySetElement
The new PropertySetElement.
ExceptionsException | Condition |
---|
ArgumentException |
The given value for name is already in use as a property set name.
-or-
name is an empty string.
-or-
name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~".
|
ArgumentNullException |
A non-optional argument was null
|
See Also