RebarInSystemGetMovedBarTransform Method

Returns a transform representing the movement of the bar relative to its default position along the distribution path.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Transform GetMovedBarTransform(
	int barPositionIndex
)

Parameters

barPositionIndex  Int32
The bar index.

Return Value

Transform
The transform representing the movement of the bar relative to its default position along the distribution path.
Exceptions
ExceptionCondition
ArgumentOutOfRangeException barPositionIndex is not in the range [ 0, NumberOfBarPositions-1 ].
Remarks
For a RebarInSystem for which individual bars can't be edited (the ones owned by AreaReinforcement) the identity transform is returned.
See Also