The sketch plane assigned to the view for model curve creation.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic SketchPlane SketchPlane { get; set; }
Public Property SketchPlane As SketchPlane
Get
Set
public:
property SketchPlane^ SketchPlane {
SketchPlane^ get ();
void set (SketchPlane^ value);
}
member SketchPlane : SketchPlane with get, set
Property Value
SketchPlaneThe sketch plane, or
for views which don't allow sketching (such as schedules) or
for views that allow model curve creation but have no current sketch plane assigned.
ExceptionsException | Condition |
---|
ArgumentNullException | Thrown when setting the property to . |
ArgumentException | Thrown when setting the property to a sketch plane that cannot be used to create model elements,
or when the input sketch plane is orthogonal to the view orientation. |
InvalidOperationException | Thrown when setting the property to a view that does not permit model curve creation, or when other errors occur. |
RemarksIf this property is set in when the current work plane is visible, the updated work plane will not be shown until the current
transaction is committed. Therefore it is recommended the Add-On commits the transaction before performing UI operations (for example, PickPoint).
See Also