SpatialElementGeometryCalculatorCanCalculateGeometry Method |
This indicates whether the input spatial element is a valid one.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool CanCalculateGeometry(
SpatialElement spatialElement
)
Public Shared Function CanCalculateGeometry (
spatialElement As SpatialElement
) As Boolean
public:
static bool CanCalculateGeometry(
SpatialElement^ spatialElement
)
static member CanCalculateGeometry :
spatialElement : SpatialElement -> bool
Parameters
- spatialElement SpatialElement
-
The spatial element to be checked if its geometry can be calculated.
Return Value
Boolean
It will return false if the room/space is not enclosed in 2d or has no location, or the height is too small.
Exceptions
See Also