CompoundStructureIsValidRegionId Method

Determines whether the specified integer is actually the id of a region in this CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsValidRegionId(
	int regionId
)

Parameters

regionId  Int32
The id of a region in this vertically compound structure.

Return Value

Boolean
True if the region is valid, false otherwise.
Exceptions
ExceptionCondition
InvalidOperationException This operation is valid only for vertically compound structures.
See Also