IExternalServiceGetName Method |
Implement this method to return the name of the service.
Namespace: Autodesk.Revit.DB.ExternalServiceAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
SyntaxFunction GetName As String
abstract GetName : unit -> string
Return Value
String
Name of the service.
RemarksAlthough an external service is uniquely identified by its Id, the Name
can identify it to the end user in UI when UI is appropriate for the service.
Beside the requirement for the name to be a non-empty string,
there are no other general restrictions imposed by the External Services Framework.
See Also