DocumentPlanTopology(Level, Phase) Property |
Get the PlanTopology of a given level in a given phase.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic PlanTopology this[
Level level,
Phase phase
] { get; }
Public ReadOnly Property PlanTopology (
level As Level,
phase As Phase
) As PlanTopology
Get
public:
property PlanTopology^ PlanTopology[Level^ level, Phase^ phase] {
PlanTopology^ get (Level^ level, Phase^ phase);
}
member PlanTopology : PlanTopology with get
Parameters
- level Level
- The level of the Plan Topology.
- phase Phase
- The phase of the Plan Topology.
Property Value
PlanTopology
RemarksAccessing plan topology requires that document is modifiable as it will actually trigger calculating plan topology if they have not been calculated yet.
The time necessary for the calculations may be significant and should be considered.
See Also