IExtensionSymbolicExtended Property |
Retrieves or set the symbolic extension status at the end
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxbool this[
int index
] { get; set; }
Property SymbolicExtended (
index As Integer
) As Boolean
Get
Set
property bool SymbolicExtended[int index] {
bool get (int index);
void set (int index, bool value);
}
abstract SymbolicExtended : bool with get, set
Parameters
- index Int32
-
Property Value
Boolean
RemarksProperty index must be 0 or 1 to indicate two ends, otherwise exceptions will be thrown.
For beams, symbolic extension setting only works when the beam is extended, mitered, and miter locked
at the end. Otherwise the setting is invalid
See Also